Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Desktop Application
Incident Report for Smartsheet
Resolved
The Smartsheet Desktop Application has remained stable since our engineers took action to mitigate the issue. At this time, we have taken all reasonable measures to ensure the stability of our system and are closing this incident.
Posted Sep 27, 2017 - 12:50 PDT
Monitoring
We have fixed the recent issue with the Smartsheet Desktop Application and are currently monitoring to make sure everything is operating normally
Posted Sep 27, 2017 - 09:44 PDT
Identified
We have identified the underlying issue, have deployed a fix, and are currently verifying recover of the Smartsheet desktop application at this time.
Posted Sep 27, 2017 - 09:40 PDT
Update
We are continuing to investigate the issues with the Smartsheet web application. Our API and Mobile application are currently functioning. We'll provide the next update at 10:00 AM, or as soon as new information is available to report.
Posted Sep 27, 2017 - 09:30 PDT
Update
Our operations team is continuing to investigate the issues with the Smartsheet web application. Our API and Mobile application are currently functioning. We'll provide the next update at 9:30 AM, or as soon as new information is available to report.
Posted Sep 27, 2017 - 08:58 PDT
Investigating
The Smartsheet Application is currently experiencing some technical issues. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Sep 27, 2017 - 08:42 PDT
This incident affected: Core Application (Sheets).