Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Loading and Saving
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Apr 16, 2019 - 10:23 PDT
Monitoring
The cause of this issue has been identified and a fix has been implemented. We are monitoring to ensure continued stability of this feature.
Posted Apr 15, 2019 - 10:30 PDT
Identified
Engineering teams have identified the issue and have taken some corrective actions. We are continuing to monitor the situation.
Posted Apr 15, 2019 - 08:45 PDT
Update
We are continuing to investigate this issue.
Posted Apr 15, 2019 - 08:25 PDT
Investigating
We are investigating reports of some customers having connection issues to app.smartsheet.com. Others may experience latency with loading and saving some sheets, reports, and dashboards. We are currently working to resolve the issue and will provide an update in the next 30 minutes.
Posted Apr 15, 2019 - 08:15 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).