Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Delay in updating cell links in sheets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 20, 2021 - 18:39 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Oct 20, 2021 - 16:39 PDT
Update
We have taken action to mitigate the issue and the cell link service is recovering. We will provide an update when this issue is resolved.
Posted Oct 20, 2021 - 13:01 PDT
Identified
We have identified the issue as caused by a delay in processing of cell link sheet data. The queued data is being processed, and the service is currently recovering. We will provide an update in 1 hour.
Posted Oct 20, 2021 - 11:55 PDT
Update
We are continuing to experience delays in updating cell links. We will provide an update in 1 hour.
Posted Oct 20, 2021 - 11:05 PDT
Update
We are continuing to experience delays in updating cell links. We will provide an update in 1 hour.
Posted Oct 20, 2021 - 10:06 PDT
Update
We are continuing to experience delays in updating cell links. We will provide an update in 1 hour.
Posted Oct 20, 2021 - 08:55 PDT
Investigating
We are currently investigating some customer reports that there is a delay in updating existing cell links in sheets. Changing a cell link source value may not update the destination. We will provide an update in 30 minutes.
Posted Oct 20, 2021 - 08:15 PDT
This incident affected: Core Application (Sheets).