Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Application Connectivity Issues
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Apr 08, 2019 - 18:04 PDT
Monitoring
Engineering has identified and implemented a fix to improve application performance. We are monitoring to ensure continued stability of this feature.
Posted Apr 08, 2019 - 08:02 PDT
Update
We are currently investigating an issue with the web application. Users may receive error messages when loading or saving the application. Please try refreshing your browser to try and resolve the issue.
Posted Apr 08, 2019 - 07:50 PDT
Investigating
We are currently investigating an issue with the web application. Users may receive error messages when loading or saving the application.
Posted Apr 08, 2019 - 07:48 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).