Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Search Functionality
Incident Report for Smartsheet
Resolved
This issue has been resolved.
Posted Jan 23, 2019 - 10:43 PST
Investigating
We're currently experiencing delays with search functionality. Newly created content may not appear in search results.
Posted Jan 23, 2019 - 08:55 PST
This incident affected: Core Application (Search).