Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Email delays
Incident Report for Smartsheet
Postmortem

On March 27th, 2021 between 1:04 PDT and 7:32 PDT, we were unable to send a subset of emails due to an expired SSL certificate. The certificate was updated and emails began processing at 7:32 PDT. 72K emails were delayed during this window, and we fully recovered at 8:24 PST. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.  

We continue to prioritize investments to scale our networking, compute, security, and other infrastructure, as well as our technical management processes that enable us to consistently deliver great experiences for our customers.

Posted Mar 31, 2021 - 10:45 PDT

Resolved
This incident has been resolved.
Posted Mar 27, 2021 - 21:44 PDT
Update
We are continuing to monitor for any further issues.
Posted Mar 27, 2021 - 20:45 PDT
Update
A fix has been implemented and delayed emails have been delivered. We are monitoring to ensure continued stability of this feature.
Posted Mar 27, 2021 - 20:44 PDT
Monitoring
We have implemented a fix and the service is recovering. We are continuing to monitor.
Posted Mar 27, 2021 - 19:42 PDT
Update
We have identified the issue and are implementing a fix.
Posted Mar 27, 2021 - 19:23 PDT
Identified
We have identified the issue and taking action to resolve.
Posted Mar 27, 2021 - 18:42 PDT
Investigating
We are currently investigating some customer reports of email delays. We will provide an update in 30 minutes.
Posted Mar 27, 2021 - 18:10 PDT
This incident affected: Notifications (Email Notifications).