Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to Access Admin Center
Incident Report for Smartsheet
Postmortem

On January 12, 2022, Admin Center was unavailable from 1:01 PM - 1:57 PM PST. A change implemented impacted the availability of the experience, which caused the page to continually show as loading. The change was rolled back around 1:42 PM PST, resolving the issue.

Posted Feb 18, 2022 - 08:41 PST

Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 16:01 PST
Monitoring
We received some customer reports of not being able to access Admin Center. A fix has been deployed and we are currently monitoring to ensure the continued stability of the app.
Posted Jan 12, 2022 - 14:01 PST
This incident affected: Administration and Audit (Admin Center).