Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
WorkApps
Incident Report for Smartsheet
Resolved
We have identified a small subset of users with WorkApps pages unable to load. The issue is now resolved and we are monitoring for further impact.
Posted Jun 09, 2021 - 17:57 PDT
Investigating
We are currently investigating reports of WorkApps pages unable to load.
Posted Jun 09, 2021 - 17:35 PDT
This incident affected: Premium Apps (WorkApps).