Smartsheet Logo
Smartsheet Reports Failing to Load
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 22, 2020 - 09:39 PDT
Monitoring
Smartsheet Reporting Service has recovered and we will continue to monitor.
Posted May 21, 2020 - 09:39 PDT
Investigating
We are investigating reports of some Smartsheet Reports failing to load. We will provide an update in 30 minutes.
Posted May 21, 2020 - 09:20 PDT
This incident affected: Reporting.