Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Managing users via Admin Center causes error, workaround available
Incident Report for Smartsheet
Postmortem

On 4/12/2022 from approximately 2:00PM to 8:40PM PST, we received reports that trying to add or remove users via the Admin Center resulted in an error. During that time, it was still possible to manage users by going to Account > Plan & Billing Info > User Management. We deployed a fix at 8:40PM, at which point managing users via the Admin Center started working again.

Posted Apr 12, 2022 - 22:29 PDT

Resolved
This incident has been resolved.
Posted Apr 12, 2022 - 22:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results for stability.
Posted Apr 12, 2022 - 20:48 PDT
Investigating
We are investigating reports where managing users (including adding/removing) via the Admin Center results in an error.

As a workaround, it is still possible to manage users by going to Account > Plan & Billing Info > User Management. We will provide an update in 60 minutes.
Posted Apr 12, 2022 - 20:09 PDT
This incident affected: Administration and Audit (User and Group Management).