Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Investigating partial sheet load errors.
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 14, 2018 - 08:05 PDT
Monitoring
Our Site Reliability team was able to restore the server. Loading and saving is now working as expected.
Posted Sep 14, 2018 - 00:49 PDT
Identified
We've identified the issue and are taking corrective actions to restore the servers.
Posted Sep 14, 2018 - 00:31 PDT
Investigating
Site Reliability Team is currently investigating an issue with one of our servers that may cause a sheet to load properly.
Posted Sep 14, 2018 - 00:23 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).