Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Errors when loading and saving sheets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 12:07 PDT
Monitoring
A fix has been identified and implemented for intermittent errors while loading and saving sheets. We are monitoring to ensure continued stability of the service.
Posted Sep 20, 2021 - 10:10 PDT
Update
A fix has been identified and implemented for intermittent errors while loading and saving sheets. We are monitoring to ensure continued stability of the service.
Posted Sep 20, 2021 - 10:09 PDT
Update
We are continuing to investigate the issue. We will provide an update in 30 minutes.
Posted Sep 20, 2021 - 09:45 PDT
Investigating
We are currently investigating some customer reports of intermittent errors while loading sheets. We will provide an update in 30 minutes.
Posted Sep 20, 2021 - 09:14 PDT
This incident affected: Core Application (Sheets).