Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Application & API
Incident Report for Smartsheet
Resolved
Our Site Reliability and Development teams were notified of a service impacting event at 08:00 PDT. By 16:25 PDT they were able to identify and resolve the issue. This failure was a software bug with our caching infrastructure. This failure caused latency for some customers.
Posted Mar 19, 2018 - 20:28 PDT
Investigating
The Smartsheet Application is currently experiencing some technical issues. We are aware of the issue and are working to get it fixed right away. Thanks for your patience.
Posted Mar 19, 2018 - 10:09 PDT
This incident affected: Core Application (Sheets), Developers and API (REST API), and Connectors (Jira Connector).