Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
WorkApps Degraded Performance
Incident Report for Smartsheet
Postmortem

On October 20th, 2024 at 07:20pm PDT, users experienced errors when trying to publish or view Workapps. Additionally, there were issues identified with "Owned by you" filter not returning any results. At ~02:40am PDT; Workapps errors were restored and all related issues resolved. We are implementing improvements based on the insights gained from this incident to help prevent similar issues in the future.

Posted Oct 22, 2024 - 03:20 PDT

Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 04:48 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2024 - 02:50 PDT
Identified
We are investigating customer reports of issues publishing new WorkApps, viewing existing WorkApps pages, and using the "Owned by you" filter.
Posted Oct 21, 2024 - 02:00 PDT
This incident affected: Advance Capabilities (WorkApps).