Smartsheet Logo

Smartsheet Status

 
Blank sheet when loading
Incident Report for Smartsheet
Postmortem

On May 5th, 2021 at 8:45 PDT, a few customers experienced an issue where they saw a blank sheet when loading. When customers logged out and logged back in, the sheet loaded properly and the issue was resolved.

Our service team deployed a fix on May 6th 5:45 AM PDT. Customers who were previously impacted with the issue were still required to log out and log back in. After monitoring the situation for a few hours, there were no new customer reports.

Posted May 06, 2021 - 20:03 PDT

Resolved
This incident has been resolved.
Posted May 06, 2021 - 11:10 PDT
Monitoring
A fix has been implemented that addressed the underlying issue. If you continue to experience this issue, logging off and on will resolve the issue. We continue to monitor the results.
Posted May 06, 2021 - 09:08 PDT
Investigating
We are currently investigating some customer reports of experiencing seeing a blank sheet when loading. Customers have confirmed that logging off and on appears to resolve the issue. We will update the status when we have completed our investigation.
Posted May 06, 2021 - 08:09 PDT
This incident affected: Core Application (Sheets).