Smartsheet Logo
Sharing Delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 21, 2019 - 01:37 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted 3 months ago. Jun 20, 2019 - 11:15 PDT
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted 3 months ago. Jun 20, 2019 - 10:35 PDT
Update
We're continuing to investigate and will provide another update in 30 minutes.
Posted 3 months ago. Jun 20, 2019 - 10:02 PDT
Investigating
We are investigating delays in sharing processing. We will provide an update within the next 30 minutes.
Posted 3 months ago. Jun 20, 2019 - 09:29 PDT