Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Search delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted May 29, 2019 - 09:19 PDT
Monitoring
Search functionality has returned to normal operating levels and we are monitoring to ensure continued stability of this feature.
Posted May 28, 2019 - 17:10 PDT
Update
We're continuing to investigate and will provide another update in 2 hours.
Posted May 28, 2019 - 15:30 PDT
Update
We're continuing to investigate and will provide another update in 30 minutes.
Posted May 28, 2019 - 14:42 PDT
Update
We're continuing to investigate and will provide another update in 30 minutes.
Posted May 28, 2019 - 13:56 PDT
Investigating
We're currently experiencing delays with search functionality. The impact is limited to newly created sheets, reports, etc. and content created in a sheet not returning in search results.
We are investigating and will provide an update within the next 30 minutes.
Posted May 28, 2019 - 13:31 PDT
This incident affected: Core Application (Search).