Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to access Admin Center
Incident Report for Smartsheet
Postmortem

Between 2:19 PM and 05:30 PM PST on Mar 12th, the Smartsheet Admin Center was inaccessible. Customers attempting to access were redirected to the legacy admin experience. We traced the root cause to an expired internal certificate, and renewed the affected certificate to address the issue.

There was a failure in our internal expiration checking system that caused this to be missed. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.

Posted Mar 12, 2021 - 19:41 PST

Resolved
This incident has been resolved.
Posted Mar 12, 2021 - 19:39 PST
Monitoring
A fix has been implemented and SysAdmins should now be able to access Admin Center. We are monitoring to ensure continued stability of this feature.
Posted Mar 12, 2021 - 17:37 PST
Update
We have identified the issue and are continuing to take action to resolve. We will provide additional updates as they become available.
Posted Mar 12, 2021 - 16:08 PST
Identified
We have identified the issue and are taking action to resolve. SysAdmins can continue to access the legacy Admin Center by navigating to User Management section from the profile drop-down. We will provide an update in 30 minutes.
Posted Mar 12, 2021 - 15:36 PST
Investigating
We are currently investigating some customer reports of not being able to access Admin Center. SysAdmins can continue access the legacy Admin Center by navigating to Plan & Billing info section from the profile drop-down. We will provide an update in 30 minutes.
Posted Mar 12, 2021 - 15:06 PST
This incident affected: Administration and Audit (Admin Center).