Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
App Slowness
Incident Report for Smartsheet
Resolved
The platform has remained stable and available post incident.
Posted May 16, 2018 - 12:21 PDT
Monitoring
As a result of issues with our app server fleet, some customers may have experienced performance issues when accessing their sheets. The performance issue lasted approximately 20 minutes before being resolved for all customers.

Our engineers continue to monitor all services.
Posted May 15, 2018 - 09:38 PDT
Investigating
The engineering team is engaged and we are investigating slowness with the web application.
Posted May 15, 2018 - 09:10 PDT
This incident affected: Core Application (Sheets).