Smartsheet Logo
Admin Center Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Oct 29, 2020 - 20:50 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of this feature.
Posted Oct 29, 2020 - 18:50 PDT
Identified
We are continuing to investigate failures accessing Admin Center. Admins can still access the legacy Account Administration by selecting Plan and Billing in the Smartsheet UI. We will provide an update as soon as they become available.
Posted Oct 29, 2020 - 17:33 PDT
Update
We are continuing to investigate failures accessing Admin Center. Admins can still access the legacy Account Administration by selecting Plan and Billing in the Smartsheet UI. We will provide an update within the next 30 minutes.
Posted Oct 29, 2020 - 17:00 PDT
Update
We are continuing to investigate failures accessing Admin Center. Admins can still access the legacy Account Administration by selecting Plan and Billing in the Smartsheet UI. We will provide an update within the next 30 minutes.
Posted Oct 29, 2020 - 16:30 PDT
Update
We are continuing to investigate failures accessing Admin Center. Admins can still access the legacy Account Administration by selecting Plan and Billing in the Smartsheet UI. We will provide an update within the next 30 minutes.
Posted Oct 29, 2020 - 16:00 PDT
Investigating
We are investigating failures accessing Admin Center and will provide an update within the next 30 minutes.
Posted Oct 29, 2020 - 15:43 PDT
This incident affected: Administration and Audit (Admin Center).