Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Connection Errors When Accessing smartsheet.com with TLS 1.1
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 07, 2019 - 17:39 PDT
Update
We are continuing to investigate connection errors when trying to access smartsheet.com with TLS 1.1. We will provide another update in the next 30 minutes.
Posted Jul 07, 2019 - 17:08 PDT
Update
We are continuing to investigate connection errors when trying to access smartsheet.com with TLS 1.1. We will provide another update in the next 30 minutes.
Posted Jul 07, 2019 - 16:32 PDT
Investigating
We are investigating connection errors when trying to access api.smartsheet.com with TLS 1.1. We will provide an update in the next 30 minutes.
Posted Jul 07, 2019 - 15:56 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).