Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Dashboards are slow to load and edit
Incident Report for Smartsheet
Postmortem

On July 7, 2021, at roughly 9:15 AM PDT, we noticed customer reports of performance issues while loading and editing Dashboards. Our investigation determined that dashboards with many metric and shortcut widgets experienced the most latency when widgets were being resized. At approximately 10:22 AM PDT, the team deployed a fix that returned performance to previous levels. We monitored post-deployment, had no additional reports from customers, and marked the issue as resolved.

Posted Jul 07, 2021 - 12:40 PDT

Resolved
This incident has been resolved.
Posted Jul 07, 2021 - 12:29 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jul 07, 2021 - 10:30 PDT
Update
We are continuing to work on a fix for this issue. We will provide an update in 30 minutes.
Posted Jul 07, 2021 - 10:05 PDT
Identified
We have received some customer reports of dashboards that are slow to load and edit. We identified the cause and are working on a fix. We will provide an update in 30 minutes.
Posted Jul 07, 2021 - 09:33 PDT
This incident affected: Core Application (Dashboards).