Smartsheet Logo

Smartsheet Status

 
DataMesh Service Outage
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 21, 2021 - 15:26 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 21, 2021 - 13:21 PDT
Monitoring
From 12:49PM - 1:04PM PST, Smartsheet Data Mesh service was unavailable and unresponsive. The service has since recovered.
Posted Jul 21, 2021 - 13:20 PDT
This incident affected: Premium Apps (Datamesh).