Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet Unavailable
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 25, 2019 - 10:32 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability.
Posted Jul 24, 2019 - 22:32 PDT
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted Jul 24, 2019 - 22:01 PDT
Update
The Smartsheet mobile application is operating normally.
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 21:46 PDT
Update
The Smartsheet mobile application is operating normally.
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 21:16 PDT
Update
The Smartsheet mobile application is operating normally.
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 20:45 PDT
Update
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 20:09 PDT
Update
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 19:39 PDT
Update
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 19:09 PDT
Update
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 18:38 PDT
Update
We are continuing to investigate and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 18:07 PDT
Investigating
We are investigating issues accessing Smartsheet and will provide an update within the next 30 minutes.
Posted Jul 24, 2019 - 17:37 PDT
This incident affected: Core Application (Sheets) and Developers and API (REST API).