Smartsheet Logo
Slow Load Times Error
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Feb 13, 2020 - 14:11 PST
Monitoring
We have determined that our customers using services provided by Cisco Umbrella, formerly OpenDNS, are having trouble using our services. If you are a Cisco Umbrella customer and are having issues accessing SmartSheet, please open a support case with Cisco Umbrella in addition to your support case with Smartsheet.
Posted Feb 12, 2020 - 14:40 PST
Update
We are continuing to investigate an issue affecting some customers ability to access Smartsheet. Our team is working with those affect customers to identify the cause. We will provide additional updates as they become available.
Posted Feb 12, 2020 - 14:14 PST
Update
We are continuing to investigate this issue and will provide an update in the next 30 minutes.
Posted Feb 12, 2020 - 12:47 PST
Update
We are continuing to investigate this issue and will provide an update in the next 30 minutes.
Posted Feb 12, 2020 - 12:12 PST
Investigating
We are currently investigating an issue where some users are getting a slow load times error message when attempting to access app.smartsheet.com. We will provide an update in the next 30 minutes.
Posted Feb 12, 2020 - 11:37 PST
This incident affected: Core Application (Sheets).