Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet website is available and Smartsheet application has not been affected.
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Aug 23, 2019 - 18:52 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Aug 23, 2019 - 13:57 PDT
Update
The www.smartsheet.com website is currently unavailable. The Smartsheet application is not impacted, and is reachable by navigating to https://app.smartsheet.com/b/home.
We are investigating this issue and will provide an update in 30 minutes.
Posted Aug 23, 2019 - 13:24 PDT
Update
The www.smartsheet.com website is currently unavailable. The Smartsheet application is not impacted, and is reachable by navigating to https://app.smartsheet.com/b/home.
We are investigating this issue and will provide an update in 30 minutes.
Posted Aug 23, 2019 - 13:12 PDT
Investigating
The www.smartsheet.com website is currently unavailable. The Smartsheet application is not impacted, and is reachable by navigating to https://app.smartsheet.com/b/home.
We are investigating this issue and will provide an update in 30 minutes.
Posted Aug 23, 2019 - 12:53 PDT
This incident affected: Core Application (Sheets).