Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Reports loading slowly
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jan 13, 2023 - 15:30 PST
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jan 13, 2023 - 13:35 PST
Identified
We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor. We will provide an update in 60 minutes.
Posted Jan 13, 2023 - 12:44 PST
Investigating
We are currently investigating customer reports of some Reports unable to be loaded. We will provide an update within 60 minutes.
Posted Jan 13, 2023 - 12:37 PST
This incident affected: Core Application (Reports).