Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
In-App Support Chat Delay
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 27 days ago. Jan 17, 2025 - 14:48 PST
Update
We are continuing to investigate an issue with our Support Chatbot service provider.
Posted 27 days ago. Jan 17, 2025 - 11:04 PST
Investigating
We received some customer reports of the in-app Contact Support chat showing a delay in responding. For immediate help, please navigate to https://help.smartsheet.com/contact to submit a case.
Posted 27 days ago. Jan 17, 2025 - 10:26 PST
This incident affected: Help and Community (In-App Chat).