Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Some reports and report widgets not loading intermittently
Incident Report for Smartsheet
Postmortem

On 10/4/22 from 1:15PM to 2:53PM PST, some reports and report widgets intermittently did not load. The issue is now resolved, and we are taking steps to help ensure this doesn't occur in the future.

Posted Oct 04, 2022 - 19:20 PDT

Resolved
This incident has been resolved
Posted Oct 04, 2022 - 17:14 PDT
Monitoring
Reports are now loading normally and we are monitoring to ensure continued stability of the service.
Posted Oct 04, 2022 - 15:14 PDT
Investigating
We are currently investigating customer feedback that some reports or report widgets in dashboards aren't loading. The issue is intermittent, and reloading the report can help it to load. We will provide an update in 60 minutes.
Posted Oct 04, 2022 - 14:39 PDT
This incident affected: Core Application (Reports, Dashboards).