This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Our workflow processing system experienced delays of up to 38 minutes on Monday, October 28th between 6:45am PT and 10:05am PT due to increased database load. Our team has resolved the issue and implemented safeguards to prevent future occurrences. All workflows were processed successfully and systems are now operating normally.
Posted Nov 05, 2024 - 13:42 PST
Resolved
This incident has been resolved.
Posted Oct 28, 2024 - 12:21 PDT
Monitoring
We have implemented a fix and are monitoring the results.
Posted Oct 28, 2024 - 10:17 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 28, 2024 - 09:56 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 28, 2024 - 09:23 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 28, 2024 - 08:53 PDT
Identified
We have identified an issue causing automated workflows to be delayed and are taking action to resolve. We will continue to provide frequent updates as we work towards resolution.
Posted Oct 28, 2024 - 08:30 PDT
This incident affected: Workflows (In App Workflows).