Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Authentication and Sign In: Login Failures for Control Center & Dynamic View Applications
Incident Report for Smartsheet
Postmortem

Due to an internal change, customers were unable to login to Control Center or Dynamic View from 9:18-10:05 AM PDT. We addressed the issue by reverting the change.

Posted Nov 06, 2023 - 11:08 PST

Resolved
This incident has been resolved.
Posted Nov 06, 2023 - 10:07 PST
Investigating
We are investigating failures logging into Smartsheet Control Center & Dynamic View Applications, and will provide an update within the next 30 minutes.
Posted Nov 06, 2023 - 09:52 PST
This incident affected: Premium Apps (Control Center, Dynamic View).