Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Intermittent Errors in Smartsheet
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 14:08 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of the Smartsheet application.
Posted Sep 29, 2020 - 12:05 PDT
Identified
We have identified the issue and taken action to resolve it. The service is recovering and we will continue to monitor.
Posted Sep 29, 2020 - 11:51 PDT
Investigating
We are currently investigating some customer reports of intermittent errors in Smartsheet. We will provide an update in 30 minutes.
Posted Sep 29, 2020 - 11:19 PDT
This incident affected: Core Application (Sheets, Sharing, Forms, Reports, Dashboards, Search, Mobile App, Conversations).