This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
On Thursday, December 4th 2025 at 8:08am, users experienced delays in Document Generation requests to download generated documents or attach them to rows. The issue occurred due to increased load on the back end service following a recent code change and was resolved by 11:30am Pacific Time.
Posted Dec 04, 2025 - 13:31 PST
Resolved
Document Generation functionality has been fully restored and is operating normally. The incident is now resolved.
Posted Dec 04, 2025 - 13:26 PST
Monitoring
We are observing stability being restored for Document Generation. We are continuing to monitor it closely to confirm full service stability. We will provide frequent updates until we reach a resolved status.
Posted Dec 04, 2025 - 11:35 PST
Identified
We have identified the issue responsible for the delays with Document Generation and are implementing a fix. We will provide frequent updates until we reach a monitoring status.
Posted Dec 04, 2025 - 11:30 PST
Update
We are continuing to investigate the cause of issues with requests to Generate Documents impacting Document Generation Automations and manual Document Generation. We will provide frequent updates until we reach a monitoring status.
Posted Dec 04, 2025 - 11:26 PST
Investigating
We are investigating issues with requests to generate documents impacting Document Generation Automations and manual Document Generation. Our team is fully engaged in addressing the situation. We will provide frequent updates until we reach a monitoring status.
Posted Dec 04, 2025 - 10:55 PST
This incident affected: Documents (Document Builder).