Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Duplicate Reminder Notifications
Incident Report for Smartsheet
Resolved
This issue has been resolved.
Posted Jan 18, 2019 - 18:00 PST
Identified
The cause of the issue has been identified and a fix is being implemented.
Posted Jan 16, 2019 - 13:16 PST
Investigating
We are investigating an issue with duplicate Reminder notifications being sent.
Posted Jan 16, 2019 - 06:52 PST
This incident affected: Notifications (Email Notifications).