Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Recovered | Smartsheet Was Unavailable
Incident Report for Smartsheet
Postmortem

On June 13th, 2023 at 11:51 AM PDT, Smartsheet's cloud provider experienced a service impacting event which caused specific Smartsheet services to have degraded performance or become fully unavailable. During that time, customers were unable to perform various actions in Smartsheet. The Smartsheet team worked closely with the cloud provider during the incident and restored service availability as dependent cloud service health improved. All Smartsheet services returned to full operational status by 3:42 PM PDT.

Posted Jun 14, 2023 - 12:54 PDT

Resolved
This incident has been resolved.
Posted Jun 13, 2023 - 17:49 PDT
Monitoring
All Smartsheet services have recovered and we are monitoring to ensure their continued stability.
Posted Jun 13, 2023 - 15:43 PDT
Update
We are continuing to work with our cloud provider as Smartsheet services are recovering or operational. We will keep the list of Smartsheet services updated and provide updates every 30 minutes.
Posted Jun 13, 2023 - 15:18 PDT
Update
We are continuing to work with our cloud provider as Smartsheet services are recovering or operational. We will keep the list of Smartsheet services updated and provide updates every 30 minutes.
Posted Jun 13, 2023 - 14:47 PDT
Update
We are continuing to work with our cloud provider as some Smartsheet services are recovering. We will keep the list of Smartsheet services updated and provide updates every 30 minutes.
Posted Jun 13, 2023 - 14:15 PDT
Identified
We have identified the issue and will continue to work with our cloud provider to resolve the ongoing service incident. We will keep the list of affected Smartsheet services updated and provide additional updates every 30 minutes.
Posted Jun 13, 2023 - 13:47 PDT
Update
We are continuing to work with our cloud provider to resolve the ongoing service incident. The list of affected Smartsheet services has been updated. We will provide additional updates every 30 minutes and will send another notification to subscribers.
Posted Jun 13, 2023 - 13:10 PDT
Investigating
One of our cloud providers is experiencing a service impacting incident causing degraded performance with Smartsheet - https://health.aws.amazon.com/health/status. We’ll continue providing updates every 30 minutes and will send another notification to subscribers with the next functional update.
Posted Jun 13, 2023 - 12:31 PDT
This incident affected: Core Application (Sheets, Sharing, Forms, Reports, Dashboards, Search, Conversations), Notifications (Email Notifications, In App Notifications, Messaging App Notifications), Workflows (In App Workflows, Bridge by Smartsheet), Resource Management (Resource Management, Smartsheet Resource Views), Premium Apps (Control Center, Dynamic View, WorkApps, DataTable), and Documents (Document Builder).