Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to Submit Contact Support Form
Incident Report for Smartsheet
Postmortem

On August 31st, between 12 and 1 PM PDT, customers received 500 errors when they tried to submit a case via our support site (https://help.smartsheet.com/contact). The issue was the result of an AWS outage. Failing over to a different AWS database resolved the issue

Posted Aug 31, 2021 - 15:03 PDT

Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 15:02 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of our help page.
Posted Aug 31, 2021 - 12:56 PDT
Investigating
We are currently investigating an issue where customers are unable to submit cases via Contact Smartsheet Support on https://help.smartsheet.com/contact.

We will provide an update in 30 minutes.
Posted Aug 31, 2021 - 12:21 PDT
This incident affected: Help and Community (Help Center).