Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
New Update Refresh Request
Incident Report for Smartsheet
Postmortem

On March 18th, 2021 at 16:30 PDT, a small number of customers encountered an error which caused Smartsheet to repeatedly prompt them to refresh their browser to get to the latest version of Smartsheet. If there were unsaved changes in the browser when the customer refreshed it, these changes were not saved. Our engineering teams identified 3 servers with incorrect configurations and removed them, correcting the problem.

Posted Mar 29, 2021 - 12:03 PDT

Resolved
This incident has been resolved.
Posted Mar 19, 2021 - 07:43 PDT
Monitoring
A fix has been implemented and customers should no longer see repeated requests to update to a new version. We are monitoring to ensure continued stability of this fix.
Posted Mar 19, 2021 - 05:38 PDT
Identified
We have identified the issue causing some customers to receive repeated refresh requests and taking action to resolve it. The service is recovering and we are continuing to monitor its progress.
Posted Mar 19, 2021 - 05:17 PDT
Update
Our team is continuing to investigate reports of customers receiving repeated requests to refresh. We will provide another update in 30 minutes.
Posted Mar 19, 2021 - 04:47 PDT
Investigating
We are currently investigating reports of customers receiving repeated requests to refresh. We will provide an update in 30 minutes.
Posted Mar 19, 2021 - 04:16 PDT
This incident affected: Core Application (Sheets, Reports, Dashboards).