Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Some application emails are delayed
Incident Report for Smartsheet
Postmortem

On June 10th, 2022 between 6 am and 9:38 am PDT, customers saw a delay in receiving e-mails sent through @mentions, sharing notifications and workflow notifications.

We addressed the issue by increasing the capacity of the email processing system. The last of the delayed emails were processed by 9:38 am PDT. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.

Posted Jun 10, 2022 - 17:10 PDT

Resolved
The fix has been implemented and the issue is now resolved.
Posted Jun 10, 2022 - 09:40 PDT
Monitoring
The issue has been identified and a fix has been implemented. We are monitoring the results.
Posted Jun 10, 2022 - 09:18 PDT
Investigating
We are currently investigating an issue some users are experiencing with email notifications being delayed.
We are investigating and will provide an update within the next 30 minutes.
Posted Jun 10, 2022 - 08:49 PDT
This incident affected: Notifications (Email Notifications).