Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Smartsheet University Unavailable
Incident Report for Smartsheet
Postmortem

On June 10th, 2023 at 11:00 PM PDT, a configuration for a service was updated that impacted the Smartsheet University site. During that time, customers were unable to able to log into Smartsheet University portal to complete their training and certification. We were able to apply a fix and service was restored to full operation by June 12th 9:05 AM PDT. We are making improvements based on our learnings from the incident to avoid similar incidents in the future.

Posted Jun 12, 2023 - 15:02 PDT

Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 10:00 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Jun 12, 2023 - 09:09 PDT
Identified
We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor. We will provide an update in 60 minutes.
Posted Jun 12, 2023 - 07:59 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 06:48 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 05:46 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 04:46 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 03:47 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 02:48 PDT
Update
We are continuing to investigate this issue.
Posted Jun 12, 2023 - 01:48 PDT
Investigating
We are currently investigating an issue where users are unable to sign into Smartsheet University.
Posted Jun 12, 2023 - 00:47 PDT
This incident affected: Help and Community (Smartsheet University).