Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Automated Workflows & Form Submissions delays
Incident Report for Smartsheet
Postmortem

On March 7th, 2023 at 7:50AM a small number of customers experienced degraded performance for workflows and form submissions. There were no lasting customer impact beyond brief performance issues. We are making improvements based on our learnings from the incident to avoid similar issues in the future.

Posted Mar 13, 2023 - 08:43 PDT

Resolved
This incident has been resolved.
Posted Mar 07, 2023 - 11:40 PST
Monitoring
A small number of customers experienced degraded performance for workflows and form submissions. There were no lasting customer impact beyond brief performance issues. We are monitoring the issue to ensure the issues are resolved.
Posted Mar 07, 2023 - 09:40 PST
Identified
Delays have improved significantly with services returning to near normal levels. We're investigating for further impact. We will provide an update within the next 60 minutes.
Posted Mar 07, 2023 - 08:57 PST
Investigating
We're investigating some impact to our service regarding Automated Workflows and Forms Submissions. We will provide an update within the next 60 minutes.
Posted Mar 07, 2023 - 08:11 PST
This incident affected: Notifications (Email Notifications), Workflows (In App Workflows), and Core Application (Forms).