Smartsheet Logo
Latency in Smartsheet
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 07:38 PDT
Monitoring
Latencies in Smartsheet services have returned to normal levels. We will continue to monitor Smartsheet services.
Posted Jun 18, 2020 - 07:38 PDT
Update
We are continuing to investigate and are monitoring Smartsheet services. We will provide an update in 1 hour.
Posted Jun 18, 2020 - 07:00 PDT
Investigating
We are investigating customer reports of general latency with Smartsheet. We will provide an update in the next 30 minutes.
Posted Jun 18, 2020 - 06:22 PDT
This incident affected: Smartsheet Application (Mobile/API, Web Application).