Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Users unable to save sheets
Incident Report for Smartsheet
Postmortem

On June 26th, between 11:17 am and 12:09 pm some customers were unable to save. Our team was able to revert the configuration change that caused the issue to resolve the incident.

Posted Jul 05, 2023 - 06:30 PDT

Resolved
This incident has been resolved.
Posted Jun 26, 2023 - 14:20 PDT
Monitoring
Engineering has implemented a fix for this issue and we are monitoring the results.
Posted Jun 26, 2023 - 12:20 PDT
Investigating
We are investigating reports of some users being unable to save sheets. We will provide an update in 60 minutes.
Posted Jun 26, 2023 - 12:10 PDT
This incident affected: Core Application (Sheets).