Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Delays in Search and Report Results
Incident Report for Smartsheet
Resolved
The platform has remained stable and systems are caught up. We are marking this incident as resolved.
Posted Mar 04, 2019 - 19:02 PST
Monitoring
Our Engineering team has taken corrective action to fix this issue. We are monitoring the platform for continued stability.
Posted Mar 04, 2019 - 10:54 PST
Investigating
We are currently seeing latency in results of Search and Reports and are working to resolve the issue.
Posted Mar 04, 2019 - 09:53 PST
This incident affected: Core Application (Reports, Search).