Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 

Delays in Workflow Automation and Sheet Access

Incident Report for Smartsheet

Postmortem

On Thursday, April 24th at 6:37 AM PDT, we began experiencing delays in workflow automations executing. This resulted in increased latency and errors when trying to load sheets. The team investigated and resolved the issues by 12 PM PDT.

Posted Apr 30, 2025 - 12:36 PDT

Resolved

This incident has been resolved
Posted Apr 24, 2025 - 12:59 PDT

Monitoring

We have identified the issue and taken action to resolve. The service is recovering and we will continue to monitor.
Posted Apr 24, 2025 - 10:34 PDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 09:27 PDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 08:36 PDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2025 - 08:14 PDT

Investigating

We have identified an incident where some users may experience intermittent issues with workflows and sheet interactions, including sheets not saving or loading as expected. This may impact the ability to trigger or complete automated processes.
We are actively investigating and will provide an update as soon as more information becomes available.
Posted Apr 24, 2025 - 07:59 PDT
This incident affected: Workflows (In App Workflows, Bridge by Smartsheet, Sharing) and Core Application (Sheets, Reports).