Smartsheet Logo
App-generated email delays
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted 24 days ago. Aug 01, 2019 - 08:08 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of email deliverability.
Posted 25 days ago. Jul 31, 2019 - 14:02 PDT
Investigating
Our monitoring systems have detected email delivery delays of some app-generated emails.
We are investigating and will provide an update within the next 30 minutes.
Posted 25 days ago. Jul 31, 2019 - 13:59 PDT
This incident affected: System Generated Emails.