This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Starting on Monday, February 9th, 2026 at 12:00PM Pacific Time, users experienced blank pages when accessing some Proof generated links. Our engineering team identified a regression. A fix was fully deployed and full proof functionality was restored for all customers on February 10th, 2026 at 11:00AM Pacific Time. We are reviewing our deployment processes to help prevent similar incidents in the future.
Posted Feb 17, 2026 - 16:36 PST
Resolved
This incident has been resolved.
Posted Feb 10, 2026 - 14:17 PST
Monitoring
A fix has been implemented and we are monitoring the results.