This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.
Get email notifications whenever Smartsheet creates, updates or resolves an incident.
Get text message notifications whenever Smartsheet creates, updates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
On September 24th, 2024 at 10:18 AM PDT, customers began experiencing intermittent errors when attempting to access sheets and forms. The team rolled back a recent configuration change and all systems were fully recovered by 10:45 AM PDT.
Posted Sep 24, 2024 - 13:08 PDT
Resolved
This incident has been resolved.
Posted Sep 24, 2024 - 13:06 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure continued stability of this feature.
Posted Sep 24, 2024 - 11:05 PDT
Investigating
We are currently investigating some customer reports of errors in Smartsheet. We will continue to provide frequent updates as we work towards resolution.
Posted Sep 24, 2024 - 10:39 PDT
This incident affected: Core Application (Sheets, Forms, Reports, Dashboards).