Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Dashboard Widgets and Reports
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jun 23, 2020 - 08:14 PDT
Monitoring
A fix has been implemented and our service has recovered. We will continue to monitor.
Posted Jun 22, 2020 - 08:15 PDT
Investigating
We are investigating reports of some Dashboard widgets and reports not loading. We will provide an update in the next 30 minutes.
Posted Jun 22, 2020 - 08:06 PDT
This incident affected: Core Application (Sheets).