Smartsheet Logo

Smartsheet Status

 
 
Redirecting Help Center
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 14:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2021 - 12:04 PDT
Investigating
Customers may experience a page loading issue while accessing Smartsheet Help Center Content. Our web team is currently investigating.
Posted Sep 20, 2021 - 11:34 PDT
This incident affected: Help and Community (Help Center).