Smartsheet Logo

Smartsheet Status

This page provides status information for Smartsheet features and functionality. Check back here to view our most up-to-the-minute information on service availability, or click the button above to be notified of interruptions to each individual service. If you are experiencing an issue not listed here try troubleshooting connection issues.

 
 
Unable to Load Some Sheets and Dashboard Widgets
Incident Report for Smartsheet
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 12:00 PDT
Monitoring
A fix has been implemented and we are monitoring to ensure the continued stability of the service.
Posted Jul 13, 2020 - 12:01 PDT
Identified
We have identified an issue where a small portion of users may experience intermittent failures loading sheets and widgets on dashboards. Users can try to refresh the sheet or dashboard to resolve these issues. We will provide an update when more information is available.
Posted Jul 13, 2020 - 09:43 PDT
Update
We are continuing to investigate an issue where some users may experience intermittent failures on load widgets on dashboards. Users can try to refresh the dashboard to resolve. We will provide an update in 30 minutes.
Posted Jul 13, 2020 - 08:28 PDT
Update
We are continuing to investigate an issue where some users may experience intermittent failures on load widgets on dashboards. Users can try to refresh the dashboard to resolve. We will provide an update in 30 minutes.
Posted Jul 13, 2020 - 07:56 PDT
Investigating
We are currently investigating an issue where some users may experience intermittent failures on load widgets on dashboards. Users can try to refresh the dashboard to resolve. We will provide an update in 30 minutes.
Posted Jul 13, 2020 - 07:28 PDT
This incident affected: Core Application (Sheets).